Написать программу которая находит корни квадратного уравнения в т.ч. комплексные. Коэффициенты уравнения вводить с консоли. Язык C++​

vasviktor vasviktor    3   27.12.2020 15:13    2

Ответы
Lena89269295717 Lena89269295717  26.01.2021 15:14

Как-то так, наверное

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

   double a, x, b, c, D;

   

   cout<<"Введите a: "; cin >> a;

   cout<<"Введите b: "; cin >> b;

   cout<<"Введите c: "; cin >> c;

   

   D = pow(b,2)-4*a*c;

   if(D>0){

   cout << "x1 = " << ((-1)*b+sqrt(D))/(2*a)<<endl;

   cout << "x2 = " <<((-1)*b-sqrt(D))/(2*a)<<endl;

   }

   else if(D==0){

       cout << "x = " << ((-1)*b)/(2*a)<<endl;

   }

   else{

    D*=(-1);

    cout<< "x1 = " << ((-1)*b)/(2*a) <<"+"<< (sqrt(D))/(2*a) << "*i" <<endl;

    cout<< "x2 = " << ((-1)*b)/(2*a) <<"-"<< (sqrt(D))/(2*a) << "*i" <<endl;

   }

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика