Написать программу ,которая на вход получает число p.на входе определяет колличество его четных и нечетных делителей c++

titomasha titomasha    2   16.06.2019 07:20    3

Ответы
kuznechikmarin kuznechikmarin  13.07.2020 06:11
#include <iostream> 
int main() {
  int x, c=0, odd=0;
  std::cin >> x;

  for (int i = 1; i<=x; i++) 
    if (!(x%i)) {
      c++;
      if(i%2)
        odd++; 
    }
  std::cout << c - odd << " HE: " << odd << std::endl;
    
  return 0; 
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика