tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу которая
Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки.
Lika1639
2 15.06.2019 08:20
3
Ответы
АлисаСилибрякова22
12.07.2020 14:38
program tref;
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Nastya4869
20.09.2019 22:50
Переведите из двоичной системы счисления в шестнадцатеричную число 1011101...
12abgh
20.09.2019 22:50
Переведите из двоичной системы счисления в шестнадцатеричную число 1011101...
samo345
07.12.2021 11:14
Определить, сколько членов суммы 1+1/2+1/4+1/8+1/16+…+1/n^2 +… необходимо взять, чтобы результат стал не менее чем 1.999....
filinenok98
07.12.2021 11:15
Какие преимущества имеет работа с записями БД в режиме формы?...
dbblyadbblya
07.12.2021 11:20
От разведчика было получено сообщение: В этом сообщении зашифрован пароль oбo последовател ность русских букв. В пароле использовались только буквы А, Е, И, К, Л,...
ХранительТьмы228
25.05.2020 23:39
1. Кто был автором первого проекта вычислительного автомата? 2. Двухпозиционный переключатель, который имеет два состояния: включено и выключено это? 3. Во время...
пик124
26.05.2020 19:25
Составить программу на алгоритмическом языке Кумир...
wasdas390wasdas390
14.04.2020 11:26
Как применяются Электронные таблицы в бизнесе?...
svetlanaivanova3
26.01.2021 19:51
Опишіть головного героя, час і місце подій у перших двох розділах повісті кількома реченнями. Який сюжетний елемент нагадує ваш опис — експозицію, зав язку, розвиток...
podsypa
26.01.2021 19:51
VENING QuMEREListen and tick the picture of Max.123...
Популярные вопросы
What would you like to do on this holiday? Think about these...
1
ТАКЖЕ НУЖНО ВСТАВИТЬ ВРЕМЕННЫЕ МАРКЕРЫ ПРЕЗЕНТ ПЕРФЕКТ ПО СМЫСЛУ!!...
3
Эксплуатация транспортного средства разрешается если 1на одну...
3
Решить уравнение б)9-(c+3)^2=0...
3
Які з прямих зображених на малюнку є парарельними...
1
Өлең неше шумақтан тұрады?өлеңнің әр шумағында неше жол бар?...
1
Один конец отрезка находится в начальной точке координатной системы...
2
Что такое ремонтные работы в быту? Какие электроинструмент можно...
1
Что из этого относится к ядерной промышленности?-относительно...
3
Встановіть відповідність: 1.автономія 2.еміграція 3.страйк 4.аграрне...
2
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.