Написать программу, которая, используя подходящую подпрограмму, возводит число х в степень n. Как можно проще.

prosto51 prosto51    3   08.05.2020 23:55    2

Ответы
sandraustaow6o7c sandraustaow6o7c  12.08.2020 21:51

Відповідь:

Если язык указать сложно - вот питон:

def stepen(x,n):

   return x**n

x = 4

n = 5

print(stepen(x,n))

либо можно максимально коротко:

def stepen(x,n):

   return x**n

print(stepen(3,2))

если нужно,чтобы ты сам вводил x и n, то:

def stepen(x,n):

   return x**n

x = float(input("x = "))

n = float(input("n = "))

print(stepen(x,n))

Пояснення:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика