Написать программу, которая генерирует. массив из n целых чисел и выводит на экран количество четных элементов.

Осьминог13 Осьминог13    3   04.04.2019 20:25    3

Ответы
suzyter839робисан suzyter839робисан  04.04.2019 22:20

java

import java.util.random;

public class myapp{

  public static void main (string {

    random rand = new random();

    int n = rand.nextint(50);

    int [] arr = new int[n];

    for(int i = 0; i < n; i++) {

      int j = rand.nextint(50);

      arr[i] = j;

    }

    for( int i = 0; i < n; i++) {

      if ( arr[i] % 2 == 0 ) {

        system.out.print(arr[i] + " ");

      }

    }

  }

}

pascal

program myapp;

var

  i, n , j: integer;

  arr: array of integer;

begin

randomize;

n : = random(50);

setlength(arr, n);

for i: = 0 to n do

  begin

    j: = random(50);

    arr[i]: = j;

  end;

for i: = 0 to n do

  begin

    if( arr[i] mod 2 = 0 ) then

      begin

        write(arr[i], ' ');

      end;

  end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика