tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу, которая формирует
Написать программу, которая формирует одномерный массив(массив температур) ,вычисляет среднее арифметическое положительных элементов массива m[1..30]
незнакомка1232
3 05.06.2019 20:50
1
Ответы
Евгешаточкару2006
06.07.2020 08:40
Var a:array[1..30] of integer;
i,sr,k:integer;
begin
for i:=1 to 30 do begin
read(a[i]);
if a[i]>0 then begin sr+=a[i]; inc(k); end;
end;
writeln(sr/k:3:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
джания
22.05.2020 10:23
Составить блок-схему алгоритма нахождения значения выражения: = − + Числа , , вводятся с клавиатуры. (Внимание! Знаменатель не должен быть равен нулю, рассмотрите возможные...
Анелетта
22.05.2020 10:22
Перевести десятичные числа0,256 0,65; 0,1875; 456,45;35,25 в двоичную, восьмеричную, шестнадцатеричную (переводим до трёх знаков после запятой)...
Yarmoshenkobchmd
08.05.2021 06:07
Нарисуйте рисунок с python turtle:...
Amina0807
08.05.2021 06:17
Выяснено,что программисты тратят рабочее время на: постановку задач - 5%,на проектирование -10%,на кодирование - 30%,на внедрение -40%,на сопровождение-15%.Составить...
Katуа07
14.12.2021 10:55
Код Цезаря: все буквы алфавита расположены по кругу, и каждая буква заменяется на третью после неё букву алфавита. Используя код Цезаря, закодируй данное слово:Дождь...
lolkek3023
14.12.2021 11:00
У исполнителя Омега две команды, которым присвоны номера: 1. прибавь 1 2. умножь на b (b-неизвестное натуральное число) Алгоритм для исполнителя Омега - это последовательность...
vaxa12345
14.12.2021 11:00
2 задания напишите на каком языке программировали: 1.B. Укладка плиткиОграничение времени 1 секундаОграничение памяти 64.0 МбВвод стандартный ввод или input.txtВывод...
eldar6213
14.12.2021 11:01
на C# Разработать программу, которая для заданной строки s: заменяет все группы стоящих рядом точек на многоточие...
настя51001
14.12.2021 11:01
напишите на каком языке программировали: E. Числа Армстронга Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input.txt Вывод стандартный...
lenalatka
14.12.2021 11:04
используя формулы и функции написатькак будет выглядеть формула для вычесления функции в табличном редакторе y=x+1/x^2...
Популярные вопросы
Сказка о потярянном времени тетрадь страница 45 3...
2
Написать 3 сложных предложения и три простых...
3
Известно, что инфекционные заболевания возникают из-за заражения мельчайшими...
2
Произведите синтаксический разбор предложения ,, коротышки тащили...
3
Начерти прямоугольник с длинами сторон 4см и 3см и вычисли его периметр...
2
Найдите неизвестный член пропорций 9: х=4: 12 1) 5целых 1 третия 2)3...
1
Сочинение по теме космичесий новый год...
3
Нужно определить тип речевой ошибки: вот предложение: председатель...
1
Произведения чисел 9 и 3 увеличь в 2 раза...
3
Варифметической прогрессии (an) известны а1=-1,2 d=3 найдите аk+2...
2
i,sr,k:integer;
begin
for i:=1 to 30 do begin
read(a[i]);
if a[i]>0 then begin sr+=a[i]; inc(k); end;
end;
writeln(sr/k:3:2);
end.