Написать программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечетными значениями.
на экран выводится исходный массив, массив с нечетными значениями и произведение.
pascal

Dariya160408589865 Dariya160408589865    2   17.09.2019 12:49    2

Ответы
DarthTyranus DarthTyranus  07.10.2020 21:49

program fantscrin;

 const n = 10;

 var a: array [1..n] of integer;

        i,s:integer;

Begin

 for i:=1 to n do

   a[i]:= random(11)+1;

 for i:=1 to n do

   write(a[i], '  ');

 p:=1;

 for i:=1 to n do

   if (i mod 2 <> 0) then

                           begin

                                p:=p*a[i];

                                write(a[i], '  ');

                            end;

 writeln('');

 writeln('Произведение = ',p);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика