Написать программу которая для заданного натурального числа n вычисляет сумму 1+1/1+2+1/1+2+3+···+1/1+2+···n в паскале .

WinnerGDWot027 WinnerGDWot027    2   21.07.2019 05:10    2

Ответы
pcd1gg pcd1gg  03.10.2020 09:25
Var s: real;    n,sn,i: integer;begin  write('n = ');  readln(n);  s:=0;  sn:=0;  for i:=1 to n do  begin    sn:=sn+i;    s:=s+1/(sn);    writeln(s);  end;  writeln('сумма ряда:  ',s);end.    
ПОКАЗАТЬ ОТВЕТЫ
spiridon spiridon  03.10.2020 09:25
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
//Наверное здесь опечатки 1+1/1+2+1/1+2+3+···+1/1+2+···n скорее всего имелось ввиду так:
//1+1/(1+2)+1/(1+2+3)+···+1/(1+2+···n)
var i,n:integer;
s,s1:real;
begin
  readln(n);
  s:=0;s1:=0;
  for i:=1 to n do begin
    s1:=s1+i;
    s:=s+1/s1;
  end;
  writeln (s);
  end.
 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика