Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат

аня11188 аня11188    1   17.06.2019 08:50    1

Ответы
aresha134589870 aresha134589870  13.07.2020 23:40
Const n=13;
var i,s,p:integer;
begin
s:=0; p:=1;
for i:=1 to n do begin
if (i mod 2 = 0) then s:=s+i;
if (i mod 2 <> 0) then p:=p*i;
end;
writeln("Сумма четных = ",s," , произведение нечетных =",p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика