Написать программу, которая будет вводить с клавиатуры положительные числа до тех пор, пока не будет введена -1. все числа должны записываться в один список и в конце работы программы из списка должны быть распечатаны сначала четные, затем не четные. на python

Лизззззззаааааа Лизззззззаааааа    2   03.10.2019 11:50    5

Ответы
IrinaKorolevskih IrinaKorolevskih  09.10.2020 14:03
Не очень корректное решение, но выводит вроде бы правильно

total = []
n = int(input())
total.append(n)
while n >= 0:
   n = int(input())
   total.append(n)
del total[-1]
for k in total:
   if k % 2 == 0:
       print(k)
   else:
       print(k)

Ссылка на код: https://pastebin.com/cRTRMS3L
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика