Написать программу которая будет определять делится ли число на 11 по признаку делимости на 11 на с++

harvey2 harvey2    1   01.10.2019 23:50    3

Ответы
polina1355 polina1355  10.09.2020 22:20

#include <iostream>


using namespace std;


int main(){

   int n;

   cout<<"n = ";

   cin>>n;

   

   int m=n,k=0;

   while(m){

       k++;

       m=m/10;

   }

   

   int arr[k];

   m=n;

   for(int i=0;i<k;i++){

       arr[i]=m%10;

       m=m/10;

   }

   

   int chet=0,nechet=0;

   for(int i=k-1;0<=i;i=i-2){

       nechet=nechet+arr[i];

   }

   

   for(int i=k-2;0<=i;i=i-2){

       chet=chet+arr[i];

   }

   

   if((chet==nechet)||(chet-nechet==11)||(chet-nechet==-11))

       cout<<"n%11=0"<<endl;

   else

       cout<<"n%11!=0"<<endl;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика