Написать программу,каторая выделит все запятые из строки st начиная с позиции р

vasnecovadaha vasnecovadaha    3   24.04.2019 12:30    5

Ответы
emir07 emir07  30.09.2020 14:26

 {Программа на Free Pascal}

Var st:string;

z,p,i:integer;

begin

z:=0;

readln(st);{Считываем строку}

read(p);{Считываем позию}

for i:=p to length(st) do if(st[i] = ',') then inc(z);{Пробегаемся по строке с позиции p и ищем ,}

writeln(z);{Выводим кол-во найденых запятых}

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика