Написать программу к : в программе генерируется два случайных числа a и b в диапазоне от 10 до 40. определить какое число больше?

Судзуми777 Судзуми777    2   24.07.2019 19:40    2

Ответы
нононононон нононононон  07.09.2020 19:37
Если паскаль, лови...
Во первых для генерации рандомного числа используется метод random(x), но он генерирует число от 1 до x, и чтоб он генерировал от какого то определенного, надо из x вычесть от какого числа генерировать, а потом к сгенерированному прибавить его random(x - n) + n. Где x - До какого числа, а n - от какого. 
Для нахождения максимального числа мы будем использовать метод max, который принимает два аргумента (какие числа надо сравнить), допустим max(5,10) вернет 10, max(-1, -5) вернет -1. Так же есть min - нахождение минимального.
...
А теперь сам код:
begin
var a := random(30) + 10; 
var b := random(30) + 10;
writeln('a:' + a); 
writeln('b:' + b);
writeln(max(a,b)); 
end.
...
Если не сложно нажми " " ;)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика