Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: s=pi *r^2

Vasya1337ez Vasya1337ez    1   09.06.2019 11:30    8

Ответы
agisheveevelina agisheveevelina  08.07.2020 08:43
procedure MinMax(var min, max: real);
var
  a: real;
begin
  if (min > max) then
  begin
    a := min;
    min := max;
    max := a;
  end;
end;

var
  r1, r2: real;
begin
  readln(r1, r2);
  r1 := pi * sqr(r1);
  r2 := pi * sqr(r2);
  MinMax(r1, r2);
  writeln('S = ', r2 - r1);
end.
Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения пл
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика