Написать программу: гречу, массой х г, рассыпают по пакетам: по а г в каждый. пакетов может быть неограниченное количество. сколько гречи будет в последнем заполненном пакете? , .

MasterGameTV1 MasterGameTV1    1   30.06.2019 20:00    1

Ответы
klimkravcnko klimkravcnko  24.07.2020 10:56
// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. 
//Пакетов может быть неограниченное количество. Сколько гречи будет в
//последнем заполненном пакете?

var x,a  : longword;
begin
  writeln ('Введите общую массу гречи, в граммах');
  readln (x);
  writeln ('Введите массу насыпаемой в пакет гречи, в граммах');
  readln (a);
  writeln ('полных пакетов будет ',(x div a));
  if (x mod a)=0  then writeln ('В последнем насыпанном пакете будет ',a,' грамм гречи')
                  else writeln ('В последнем насыпанном пакете будет ',(x mod a),' грамм гречи');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика