Написать программу генерирующую и выводящую на экран стозначное целое число.определить делится ли данное стозначное число на 3 или 9

baron2032012 baron2032012    3   18.03.2019 00:30    2

Ответы
vovbakum vovbakum  25.05.2020 21:54

Program zadacha;

Var x:integer;

Begin

  Randomize;

  x:=random(9999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999999)+1000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000;

  If (x mod 3=0) then begin

    If (x mod 9=0) then writeln('Делится на 3 и на 9);

  End;

  If (x mod 3=0) then begin

    If (x mod 9>0) then writeln('Делится только на 3);

  End;

  If (x mod 9=0) then begin

    If(x mod 3>0) then writeln('Делится только на 9);

  End; 

End.

 

 

P.S. Вы уверены, что СТОзначное число?

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика