Написать программу формирующую двумерный массив размером 4х4 и выводящую на экран максимальное количество элементов этого массива

Валерушка8 Валерушка8    2   18.05.2019 00:40    0

Ответы
nastycherry1 nastycherry1  11.06.2020 05:40

 

 Видимо имеется ввиду выводящий максимальны элемент этого массива

 

 В данном примере матрица формируется при случайных чисел 

 

 

program MatrixMax;

Uses Crt;
   type matrix=array[1..4,1..4] of real;

   var m:matrix;

          max:real;

 

 

{Порождение матрицы случайным образом}
procedure Auto;
var i,j:integer;
begin
    randomize;
    for i:=1 to 4 do
           begin
               for j:=1 to 4 do
                     begin
                         m[i,j]:=25+random(21);
                     end;
             end;
end; 

  

{Вывод матрицы на экран} 

 

procedure PrintMatrix(mas:matrix );
var j,k:integer;
begin
 for k:=1 to 4 do
       begin
           for j:=1 to 4 do
              begin
                 write(mas[k,j]:7:2);
             end;
    writeln;
       end;

end; 

 

 

 

 {Нахождение максимального элемента}
procedure Мax;
var i,j:integer;
begin
    max:=m[1,1]
    for i:=1 to 4 do
           begin
               for j:=1 to 4 do
                     begin
                        if (max<m[i,j]) then max:=m[i,j];
                     end;
             end;
end;

 

 

 begin

      Clrscr;

       Auto;

       PrintMatrix;

       Max;

        writeln;

        writeln('Максимальный элемент матрицы: ',max);

 

 

 end. 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика