Написать программу для вычисления произведения и среднего арифметического чисел от 1 до n, которые: 1) нечётные и кратны 3

emmadetes emmadetes    1   06.07.2019 15:20    0

Ответы
ulaborodina57 ulaborodina57  02.10.2020 21:30
Uses crt;
var i,b,x,q:integer;
c:real;
var a: array [1..3] of integer;
begin
clrscr;
writeln('Введите числа');
for i:=1 to 3 do
read(a[i]);
q:=1;
for i:=1 to 3 do begin
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then x:=x+1;
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then b:=b+a[i];
if (a[i] mod 3 = 0) and ( a[i] mod 2 = 1 )then q:=q*a[i];
c:=b/x;
end;
writeln('Среднее арифметическое = ',c);
writeln('Произведение = ',q);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика