Написать программу для С#!
Написать программу решения следующей задачи: Определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). ответ вывести на печать.​

bbayy bbayy    2   01.06.2020 08:57    8

Ответы
amanullina amanullina  15.10.2020 12:42

вот возможный вариант, если числа номер вводится с клавиатуры:

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int a, b, c, d, e, f;

int x = 0;

cout << "Введите номер билета: ";

cin >> a >> b >> c >> d >> e >> f;

x = a + b + c;

if ( x == d + e + f)

 cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Ваш билет счастливый!";

else cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Увы, ваш билет не счастливый.";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика