Написать программу для решения : сравнить первую и последнюю цифру натурального четырёхзначного числа n. на экране должен появиться запрос на ввод числа и результат решения , например 1) вводится число 1475, выводится «первая цифра меньше последней: 1< 5». 2) вводится число 3452, выводится «первая цифра больше последней: 3> 2». 3) вводится число 7457, выводится «первая цифра равна последней: 7=7»

куллллл куллллл    2   03.10.2019 06:20    3

Ответы
insarycheva insarycheva  09.10.2020 13:25

var n:integer;

begin

write('Введите 4-х значное число: ');

readln(n);

if n div 1000 = n mod 10 then write('Первая цифра равна последней: ',n div 1000,'=',n mod 10)

else if n div 1000 > n mod 10 then write('Первая цифра больше последней: ',n div 1000,'>',n mod 10)

else write('Первая цифра меньше последней: ',n div 1000,'<',n mod 10)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика