Написать программу для решения следующей : вычислить сумму и количество положительных элементов последовательности.

barmeb11 barmeb11    2   26.05.2019 23:40    3

Ответы
DENCHIK23371 DENCHIK23371  01.10.2020 12:22
Var
  sum, count, t : integer;
begin
  sum := 0; count := 0;
  while not eoln do
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.

если количество элементов указано
var
  sum, count, t, n, i : integer;
begin
  sum := 0; count := 0;
  read (n);
  for i := 1 to n do 
  begin
    read (t);
    if t > 0 then
    begin
      sum := sum + t;
      count := count + 1;
    end;
  writeln (sum, ' ', count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика