Написать программу для решение - посчитать количество чисел от 1 до 1000 кратных 7 и честных ( провереть кратность 7 командой mod введя условие если в цикл)

maratsultanbekкатя maratsultanbekкатя    2   29.06.2019 11:10    1

Ответы
katwyn katwyn  23.07.2020 12:19
Var
   x,i,y:integer;
begin
  for i:=1 to 1000 do
    begin
      x:= i mod 7;
      if x=0 then
        begin
        y:=y+1;
        writeln (i);//строка выводит все числа кратные семи. она подлежит удалению
       end;
     end;
  writeln (y);
end.
ПОКАЗАТЬ ОТВЕТЫ
ghj42 ghj42  23.07.2020 12:19
Var
   count,i:integer;
begin
  i:=0;count:=0;
 repeat
     i:=i+2;
     if i mod 7 =0 then count:=count+1;
 until i>=1000;
 writeln(count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика