Написать программу для подсчёта суммы цифр чисел, записанных в файл. (язык с++)

12309874 12309874    2   15.09.2019 04:40    2

Ответы
фаргана4 фаргана4  07.10.2020 16:10
#include <iostream>
#include <iomanip>
#include <fstream>
using namespace std;

int main() {
  int n;
  float s=0;
  ifstream f;
  f.open("input.txt");
  while(!f.eof()) {
     f>>n;
     while (n>0) { s+=n%10; n=n/10; }
  }   
  f.close();
  cout<<s<<endl;
  system("pause");
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика