Написать программу для паскаля. дан массив x размера n(n=10) целых чисел, содержащий как положительные, так и отрицательные элементы. упорядочить массив следующим образом: сначала идут отрицательные числа, по невозрастанию, потом положительные, по неубыванию.

Sasha1234563673727 Sasha1234563673727    3   28.05.2019 05:40    6

Ответы
OlyaPo1 OlyaPo1  25.06.2020 15:51
Program gt;
var  A,B,C:array[1..1000]of longint;
  p,l,n,i,j,k,w:longint;
begin
n:=10;
for i:=1 to n do
read(A[i]);
k:=0;w:=0;
for i:=1 to n do
begin
if(A[i]<0)then begin
k:=k+1;b[k]:=a[i];
end;
if(A[i]>0)then begin
w:=w+1;
c[w]:=a[i];
end;
end;
for i:=1 to k-1 do
for j:=1 to k-i do
begin
p:=b[j];l:=b[j+1];
if b[j]<b[j+1] then begin
b[j]:=l;b[j+1]:=p;
end;
end;
for i:=1 to k do
write(b[i],' ');
for i:=1 to w do
write(c[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика