Написать программу для паскаль абц, но при не слишком сложных операций. "пусть n - натуральное число и пусть означает 1*3*5**n для нечетного n и 2*4**n для четного n. вычислить " - факториал. т.ею нужно ввести натурально число(например 5), а программа должна посчитать произведение нечетных чисел(1*3*5=15)

TheOksikPlay TheOksikPlay    2   26.07.2019 06:30    3

Ответы
uylia7 uylia7  15.09.2020 23:52
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var n,i: integer;
p:BigInteger;
begin
  p:=1;
  write('Введите N ');readln(n);
  if n mod 2<>0 then i:=1 else i:=2;
      while i<=n do begin
        p:=P*i;
        i:=i+2;
      end;
    writeln(p);
end.

Тест №1
Введите N 6
48

Тест №2
Введите N 5
15
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика