Написать программу для pascal. вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

алек36 алек36    3   29.07.2019 18:30    1

Ответы
Яся83 Яся83  03.10.2020 16:50
Var a,b,k1,k2,s:integer; 
begin 
s:=0; 
k1:=0; 
writeln('Введите начало и конец отрезка'); 
read(a,b); 
k2:=b-a+1; 
repeat 
if b<0 then break; 
s:=s+b; 
b:=b-1; 
inc(k1); 
until (b=-1) or (b=a-1); 
writeln('Сумма всех целых положительных чисел на отрезке = ',s); 
writeln('Количество отрицательных целых чисел = ', k2-k1); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика