Написать программу для pascal abc.дан массив действительных чисел,размерность которого n.подсчитать,сколькоив нем отрицательных,положительных и нулевых элементов.

EdSid EdSid    1   16.06.2019 16:40    2

Ответы
yulyaakimova0 yulyaakimova0  13.07.2020 15:25
Program aaa;
var 
a,b,c,n,i:longint;
M:array[1..1000000] of real;
begin
read(n);                //
for i:=1 to n do      //если считывать массив не нужно, то удалить   
  read(M[i]);          //   
a:=0;
b:=0;
c:=0;
for i:=1 to n do
begin
  if M[i]>0 then inc(a);
  if M[i]=0 then inc(b);
  if M[i]<0 then inc(c)
end;
writeln('положительных элементов:',a);
writeln('нулевых элементов:',b);
writeln('отрицательных элементов:',c)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика