Написать программу для определения существует ли треугольник по заданным координатам в рascal abc.

130181 130181    3   19.05.2019 10:54    3

Ответы
Данилка20022002 Данилка20022002  12.06.2020 15:54

Объяснение:

var x1,y1,x2,y2,x3,y3, AB, BC, AC:real;

function a(x1,y1,x2,y2:real):real;

begin

Result:= sqrt(sqr(x1-x2)+sqr(y1-y2));

end;

begin

readln(x1, y1);

readln(x2, y2);

readln(x3, y3);

AB :=a(x1,y1,x2,y2);

BC :=a(x2,y2,x3,y3);

AC :=a(x1,y1,x3,y3);

if (AB<BC+AC) and (BC<AC+AB) and (AC<BC+AB) then writeln('такой треугольник существует')

else writeln('такой треугольник не существует');

writeln(AB, ' ', AC, ' ', BC);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика