Написать программу для одномерного массива подсчёт кол-ва элементов массива, выше 30

sashaiseneev sashaiseneev    1   02.10.2019 13:10    2

Ответы
Anna45w456 Anna45w456  11.08.2020 11:15
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(ReadInteger('n='), -99, 99);

 a.Println;

 Writeln('Элементов со значением, превышающим 30: ',

     a.Where(t -> t > 30).Count)

end.

Пример

n= 17

29 8 -26 51 -32 -35 46 95 -90 58 66 64 19 -3 34 -8 45

Элементов со значением, превышающим 30: 8

ПОКАЗАТЬ ОТВЕТЫ
666777зпа 666777зпа  11.08.2020 11:15

const n=10;

var a:array [1..n] of integer;

i,k:integer;

begin

for i:= 1 to n do

begin

a[i]:=Random(90)+10;

write(a[i],'  ');

if a[i]>30 then k:=k+1

end;

writeln;

writeln ('Кол-во элементов массива, выше 30, равно: ',k)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика