Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения. паскаль

KOROTKOVAKATA KOROTKOVAKATA    1   30.06.2019 05:50    0

Ответы
оксана755 оксана755  02.10.2020 15:57
Program a1;
var x,y,s: integer;
begin
read (x,y);  
write(x,'*',y,'=');  
while x>0 do 
 begin 
    If ((x mod 2) <>0) then s:=s+y; 
    x:= x div 2;  
   y:=y+y;
 end;
write(s);
writeln();
readln();
end.
Русский умножения
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика