tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу для
Написать программу для нахождения а) нод, б) нок двух натуральных чисел а, b.
anitayun0518
3 29.05.2019 16:40
1
Ответы
сашагушцщц
28.06.2020 20:59
Program gt1;
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
andrei79smirnov
30.04.2020 13:14
Нарисуйте иконки инструментов Sketch UP и их назначения...
pestowasonya
30.04.2020 13:14
В таблице приведены за и количество страниц, которые нашел поисковый сервер по этим за в некотором сегменте Интернета: За Количество страниц (тыс.)слон & волк250волк...
MrRobik
30.04.2020 13:15
Какие элементы базы данных могут изменять пользователи? Укажите один или несколько правильных вариантов ответа: индексы связи таблиц ключи записи поля...
Лераuse
30.04.2020 13:15
2.Напишите программу вычиления следующих выоажений:а)Информатика 8 классНА ПАСКАЛЕ...
97shadesofblue
30.04.2020 13:15
4. Рассмотрите программу, напечатанную ниже. Укажите имя программы; сколько и какого типа в ней переменных; перечислите, какие функции встречаются. 5. Напишите, что...
maryvysotinap08vi8
23.10.2020 10:59
Представление результатов проекта Посмотри видеоролик. Изучи программуWindows Movie Maker, найди два правильныхответа.DN,INCМЕКТЕНyoutube.comВерных ответов: 2Windows...
Oneheest
23.10.2020 10:58
Расположить в порядке возрастания в зависимости от объема информации: (от меньшего к большему) 80 бит 1024 байта 1024 Мб 1 байт 1024 Кбайт...
александра7896
25.08.2019 18:40
Спрограммированием! 1.из массива р, содержащего 10 элементов, сформировать массив т по правилу: a. т(к)=к*р(к), где к – чётные, т(к)=р(к)/к, где к – нечётные. 2. в...
Qwerfcsfvfw
25.08.2019 18:40
Вывести на экран все трехзначные натуральные числа, сумма цифр которых не превосходит заданное пользователем (введенное с клавиатуры) число. pascal abc для 8 класса...
visskikross
02.10.2019 16:04
Нужно нарисовать блок схему для решение . 2 вариант...
Популярные вопросы
Вычислите вес стальной отливки объемом 20 см3...
1
Как сделать фото на ники я на айпаде...
2
Из обыкновенной дроби нужно перевести в десятичную ,1\2 1\3 1\4...
2
Антонимы к слову полезный с приставкой з или с...
3
Скаким из данных веществ кислород не взаимодействует: а)с серой...
2
Цитатна характеристика павлуся з твору скарб...
3
Уравнение тип реакции 1) feo + h2so4 = feso4+h2oa) соединения 2)...
2
Рассказ на о своем увлечении футболом...
1
Написать сочинение на тему мой любимый подарок...
3
Радиус кругового сектора равен 6 см, а его угол равен 30 градусов.сектор...
3
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД