Написать программу. для целого числа k от 1 до 99 напечатать фразу: "мне k лет, учитывая, что может быть год, лет, года. год: 1, 21, 31, (n mod 10=1). лет: 5-20, 25-30, 35-40, 45- (n mod 10=0, 5, 6, 7, 8, 9). года: 2, 3, 4, 22-24, 32-34, 42- (n mod 10=2, 3, 4).
begin
readln(k);
case (k mod 10) of
1 : writeln ('Мне ',k,' год');
0, 5, 6, 7, 8, 9 : writeln ('Мне ',k,' лет');
2, 3, 4 : writeln ('Мне ',k,' года');
end;
end.
Вот рабочее решение