написать программу для c++. Дан двумерный массив целых чисел. имеются ли числа, оканчивающиеся нулем, в правом верхнем или в правом нижнем углу.

лиза2291 лиза2291    2   30.06.2021 07:06    4

Ответы
katcornewa katcornewa  30.07.2021 07:45

#include <iostream>

#include <cmath>

   

void mas (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           array[i][j] = rand()%5;

       }

   }

}

void text (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           std::cout << array[i][j];

       }

   } std::cout << std::endl;

}

void NUUL (int array[3][3]){

   for (int i(0); i!=3; i++){

       for (int j(0); j!=3; j++){

           if (array [0][0] == 0){

               std::cout << "array[0][0] == 0" << std::endl;

           }

           else if(array[3][3] == 0){

               std::cout << "array[3][3] == 0" << std::endl;

           }

       }

   }

}

 

 

void main (){

 

   int arr[3][3];

       mas(arr);

       text(arr);

       NULL(arr);

 

 

 

   system ("pause");

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика