Написать программу для: 1. определите есть ли в данном массиве отрицательные элементы 2. есть ли два одинаковых элемента 3. есть ли данное число в среди элементов массива вы мне , заранее!

пандочка94 пандочка94    1   26.05.2019 05:20    5

Ответы
justdoit5 justdoit5  22.06.2020 14:37
Написано в Pascal:

Program Zadacha;
Const n = 10;
Var a: Array [1..n] of Integer;
B, c, i, j: Integer;
d, e: Boolean;
Begin
WriteLn('Введите ', n, ' целых чисел через пробел и нажмите Enter');
For i := 1 To n Do
Read(a[i]);
Write('B = ');
ReadLn(B);
c := 0;
For i := 1 To n Do
If a[i] < 0 Then
c := c + 1;
WriteLn('Количество отрицательных элементов массива равно ', c);
d := False;
For i := 1 To n Do
Begin
c := a[i];
For j := i + 1 To n Do
If c = a[j] Then
d := True;
End;
If d = True Then
WriteLn('В массиве есть одинаковые элементы')
Else
WriteLn('В массиве нет одинаковых элементов');
e := False;
For i := 1 To n Do
If a[i] = B Then
e := True;
If e = True Then
WriteLn('В массиве есть элемент, равный ', B)
Else
WriteLn('В массиве нет элемента, равного ', B);
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
mrnazar228 mrnazar228  22.06.2020 14:37
Язык Python

A = [1,2,3,4,5,6] # Массив
B = 10

# 1 Задание
A.sort()
if A[0]<0:
  print "Есть отрицательные элементы"
else:
  print "Отрицательных элементов нет"
# 2 задание
cnt = len(A)
for i in A:
  if A.count(i)>1:
    print "Есть повторяющиеся элементы"
    break
  cnt-=1
if not cnt:
  print "Повторяющихся элементов нет"
# 3 задание
if B in A:
  print "В входит в массив"
else:
  print "В не входит в массив"
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика