Написать программу(delphi или pascal) для вычисления минимального произведения отрицательных подряд идущих элементов одномерного массива.

Ravshanbekovna Ravshanbekovna    3   09.08.2019 03:00    8

Ответы
anelya033 anelya033  04.10.2020 06:27
Const n=10 ;var A: array [1..n] of integer;p,  min, i, : integer;beginrandomize;for i:= 1 to n dobeginA[i]:= -100 + random (200);write (A[i]: 5);end;writeln;min:=100000000;p:=1;for i:=1 to n doif A[i] < 0 then  p:=p*A[i]      else      Begin        if p< min then min:=p;              p:=1;      End;       if p<min then min:=p;        writeln ('min p=' , min );end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика