tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу. даны
Написать программу. даны 2 числа a и b. найти среднее арифметическое всех чисел кратных 3 из интервала [a,b].
1234554321123456
1 27.06.2019 08:20
6
Ответы
Ршмшрмпширщ
02.10.2020 12:58
var
i, j, a, b: integer;
s: real;
begin
write('Введите a: '); readln(a);
write('Введите b: '); readln(b);
for i := a to b do
if (i mod 3) = 0 then
begin
s := s + i;
inc(j);
end;
s := s / j;
writeln('ответ: ', s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
BONDsCNOPCOI
13.09.2021 02:14
Привезти 5 примеров действий без инфармации...
LISAIZKOSHMAROV
21.04.2019 18:57
Для заданного числа n составьте программу вычисления значения квадратов! первых n чисел...
Lalker1337
01.09.2019 13:50
Нужно узнать с программы или неважно чего ответ данного выражения: (15082015^26082015)%17082016 (где ^ - степень, а % - mod (или же остаток от надо, никак не могу...
Vladislava256
01.09.2019 13:50
Сколько символов в тексте содержащем 2 кбайта информации, если мощность алфавита равна 128 символа....
DILLERONLOLOLOSHKA
02.04.2019 03:40
№1 выделите попарно общие и единичные понятия и запишите их в соответствующие столбцы таблицы : общее понятие единичное понятие понятия: композитор,пушкин,художник,чайковский,озеро,горы,репин,поэт,байкал,париж,карпаты,филосов,город,сократ,полководец,чита,суворов,учёный,река,ньютон,лена,!...
miqwq
02.04.2019 03:40
Дано трёхзначное число. напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые...
Лдаслл183
02.04.2019 03:40
Сколько строк в тексте если он занимает 5 страниц по 65 символов в каждой строке? при составлении текста использовали 128-символов алфавит, и сообщение содержит...
ritapechyonkina77
02.04.2019 03:40
Составьте алгоритм для вычисления произведения чисел 5,10,. у меня есть начало, вот оно закончите : r; =5, n: =55; i: =i+5....
fainanem
02.04.2019 03:40
Составть программу для следующих , в паскале а)с клавиатуры вводится два вещественных числа.найти целую часть от произведения двух вещественных чисел. б)с клавиатуры...
timofeierofeev
02.04.2019 03:40
Как проносят олимпийский огонь по странам?...
Популярные вопросы
Согласны ли вы с утверждением? В 60–70-е гг. XIV в. Москва разгромила...
1
Кому принадлежат слова? С какими событиями они связаны? Вечевому...
1
Из перечня вычеркните названия трех городов, войск которых не...
2
Перечислите народы, вошедшие в состав единого Российского государства...
2
Выясните, интересы каких групп населения защищал или ограничивал...
3
В 1510-1511 гг. монах Псковского Елеазарова монастыря Филофей...
2
К деятельности какого правителя: 1) Василия II; 2) Ивана III;...
2
Объясните слова и выражения Подсечная система земледелия...
2
Какие яркие, впечатляющие факты русской истории XIV-XV вв. свидетельствуют...
2
Где проживала основная масса населения России к середине XVI...
1
i, j, a, b: integer;
s: real;
begin
write('Введите a: '); readln(a);
write('Введите b: '); readln(b);
for i := a to b do
if (i mod 3) = 0 then
begin
s := s + i;
inc(j);
end;
s := s / j;
writeln('ответ: ', s);
end.