Написать программу: "дано четырехзначное число.что больше: сумма цифр,стоящих на четных местах,или сумма цифр,стоящих на не четных местах? "

Карнова Карнова    2   02.06.2019 07:30    5

Ответы
twv05355 twv05355  01.10.2020 17:13
Var a,s1,s2:integer;
begin
read (a);
if (a>=1000)and (a<=9999)then
begin
s1:=(a mod 10) + ((a mod 1000) div 100);
s2:=(a div 1000) + ((a mod 100) div 10);
if (s1>s2)then writeln ('Сумма цифр,стоящих на четных местах больше суммы цифр, стоящих на нечетных местах');
if (s1<s2)then writeln ('Сумма цифр,стоящих на нечетных местах больше суммы цифр, стоящих на четных местах');
if (s1=s2)then writeln ('Сумма цифр,стоящих на четных местах равна сумме цифр, стоящих на нечетных местах');
end
else writeln ('Вы ввели не 4-ёхзначное число');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика