Написать программу: дано 5 произвольных натуральных чисел. найти среднее арифметическое отрицательных кратных пяти.

snyaSergeeva snyaSergeeva    2   16.07.2019 07:50    2

Ответы
денисвеликий денисвеликий  03.10.2020 05:44
Program z1;
var
mas: array[1..10] of integer;
i,s,sr,k: integer;
begin
s:=0;
k:=0;
writeln('Введите 5 чисел');
for i:=1 to 5 do
begin
readln(mas[i]);
if (mas[i]<0) and (mas[i] mod 5=0) then
begin
s:=s+mas[i];
k:=k+1;
end;
end;
sr:=s div k;
writeln('Среднее арифметическое чисел, кратных 5, равно ',sr);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика