Написать программу, : ) дана последовательность n целых чисел. отсортируйте ее. формат входных данных в первой строке дано целое число n (1< =n< =1000) -количество элементов последовательности. во второй строке заданы сами элементы целые числа, не превосходящие по абсолютной величине 10^9.выведите n чисел элементы заданной последовательности в порядке неубывания. через input и output. язык - паскаль.

dionakavinep08o5z dionakavinep08o5z    1   14.06.2019 20:00    18

Ответы
kirstav64 kirstav64  12.07.2020 09:08
var
  n, i, j, AskTheMountains: longint;
  a: array of longint;
  fl: Text;

begin
  assign(fl, 'input.txt');
  reset(fl);
  readln(fl, n);

  SetLength(a, n);
  for i := 0 to (n - 1) do
    readln(fl, a[i]);

  close(fl);
  assign(fl, 'output.txt');
  rewrite(fl);
  
  for i := 0 to n - 1 do
    for j := i to n - 1 do
      if (a[i] > a[j]) then
      begin
        AskTheMountains := a[i];
        a[i] := a[j];
        a[j] := AskTheMountains;
      end;

  for i := 0 to n-1 do
    writeln(fl, a[i]);
  close(fl);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика