Написать программу : дан двумерный массив а, состоящий из n элементов. найти минимальный из элементов этого массива с нечетными индексами и максимальный из элементов с четными индексами.

IlachinaViktori IlachinaViktori    2   12.09.2019 22:30    3

Ответы
alfa2009 alfa2009  04.08.2020 06:58
Var
  a: array [1..100] of integer;

begin
  var N := ReadInteger;
  var mmax := Integer.MinValue;
  var mmin := integer.MaxValue;
  for var i := 1 to N do
  begin
    readln(a[i]);
    if (i mod 2 <> 0) and(a[i] < mmin) then mmin := a[i];
    if (i mod 2 = 0) and (a[i] > mmax) then mmax := a[i]
  end;
  writeln('Минимальный элемент массива с нечетным индексом: ', mmin);
  writeln('Максимальный элемент массива с четным индексом: ', mmax)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика