Написать программу, чтобы она удаляла все нечетные числа в строке

Светило111Науки Светило111Науки    1   26.12.2019 13:49    2

Ответы
Liz0997 Liz0997  10.10.2020 23:26

var

 s, p : string;

 i : integer;

begin

 write('строка: ');

 readln(s);

 writeln(s);

 for i := length(s) downto 1 do  

   if s[i] in ['1', '3', '5', '7', '9'] then delete(s, i, 1);

 for i := length(s) downto 1 do

   if s[i] in ['0', '2', '4', '6', '8'] then

   begin

     p := '(' + s[i] + ')';

     delete(s, i, 1);

     insert(p, s, i)

   end;

 writeln(s);

 readln

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
nbis2000 nbis2000  10.10.2020 23:26

PascalABC.NET

begin

 var s :='26 декабря 2019 года, четверг, 15 час 43 мин, за окном +3.';

 s := s.Remove

     (

     s.MatchValues('\d+')

     .Select(p -> p.ToInteger)

     .Where(p -> p.IsOdd)

     .Select(p -> p.ToString)

     .ToArray

     );

 Println(s) // 26 декабря  года, четверг,  час  мин, за окном +.

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика