Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки матрицы а(10,8) и вывести ее в виде таблицы.

Ujwy Ujwy    1   12.11.2019 22:15    8

Ответы
Gkdm Gkdm  05.08.2020 10:19

#include <iostream>

#include <iomanip>

using namespace std;

int main()

{

   int m=10, n=8;

   int a[m][n];

   srand(time(0));

   for(int i=0; i<m; i++)

   {

       for(int j=0; j<n; j++)

       {

           a[i][j]=-99+rand()%199;

           cout << setw(4) << a[i][j];

       }

       cout << endl;

   }

   cout << endl;

   // сортировка

   int t;

   for(int i=0; i<m; i++)

   {

       for(int k=n-2; i>=0; i--)

           for(int j=0; j<=k; j++)

               if(a[i][j] > a[i][j+1])

               {

                   t=a[i][j]; a[i][j]=a[i][j+1]; a[i][j+1]=t;

               }

       for(int j=0; j<n; j++)

           cout << setw(4) << a[i][j];

       cout << endl;    

   }

   return 0;

}

Прилагается пример вывода.


Написать программу c++ для решения следующей : упорядочить по возрастанию элементы каждой строки мат
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика