Написать программу c++ cin cout (Двумерные массивы) Условие
Требуется определить количество выплаты n рублей монетами по 1, 2, 5 и 10 рублей.

входные данные выходные данные
13 16
42 220
5 4

Vika1123556789 Vika1123556789    2   14.05.2021 16:23    2

Ответы
skybeast skybeast  13.06.2021 16:25

#include <iostream>

using namespace std;

int a[4] = {1, 2, 5, 10}, b = sizeof(a)/sizeof(a[0]), m[100];

 

int f(int s, int j = 0, int k = 0) {    

   if (j >= b || s < 0)

       return 0;

   else if (s == 0) {

       for(int i=0; i<k; i++)  

           return 1;

   } else {

       m[k]=a[j];  

       return f(s - a[j], j, k + 1) + f(s, j + 1, k);

   }

}

int main() {

 int n; cin >> n;

 cout << f(n);

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика