Написать одну программу для вычисления трех логических переменных: rez1, rez2, rez3. используя следующие данные. Три вычисления в одной программе.Даны значения целочисленных переменных: а = 10, b = 20. Чему будет равно значение логической переменной rez после выполнения операции присваивания? а) rez:=(а=10) or (b>10) б) rez:=(а>5) and (b>5) and (a 20)

лисичка73 лисичка73    3   12.11.2020 08:33    8

Ответы
Подпишись1 Подпишись1  12.12.2020 08:39

program z1;

var a,b: integer;

rez1, rez2, rez3: boolean;

begin

a := 10;

b := 20;

rez1:=(a=10) or (b>10);

rez2:=(a>5) and (b>5) and (a>20);

rez3:=(not(a<15)) or (b>20);

writeln('rez1 = ',rez1,'     rez2 = ',rez2,'     rez3 = ',rez3)

end.

Объяснение:

Объявляем переменные rez1, rez2, rez3 - логическими.

Пишем условия

Выводим на экран

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика