НАПИСАТЬ КОД (питон) На вход программе подается натуральное число nn, затем nn строк, затем число kk — количество поисковых запросов, затем kk строк — поисковые запросы. Напишите программу, которая выводит все введенные строки, в которых встречаются все поисковые запросы.

Формат входных данных

На вход программе подаются натуральное число nn — количество строк, затем сами строки в указанном количестве, затем число kk, затем сами поисковые запросы.

Формат выходных данных

Программа должна вывести все введенные строки, в которых встречаются все поисковые запросы.

Примечание. Поиск не должен быть чувствителен к регистру символов.

DamirLike DamirLike    3   08.11.2021 08:54    212

Ответы
Kiper222 Kiper222  08.12.2021 08:56

c = []

a = []

b = []

for i in range(int(input())):

   a.append(input())

for k in range(int(input())):

   b.append(input())

for q in a:

sum = 0

for w in b:

 if w.lower() in q.lower():

  sum = sum + 1

  if sum == len(b):

   print(q)

Объяснение:

Сам разберись тоже, полезно будет)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика