tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать код на языке паскаль.
Написать код на языке паскаль. подсчитать количество чётных цифр в исходной символьной строке и распечатать все, кроме пробелов, знаков операций и знаков препинания.
робингуд228
3 14.07.2019 19:20
5
Ответы
ndiana2402
03.10.2020 04:15
// PascalABC.NET 3.0, сборка 1128
begin
var Delim:=' .,+-*/;:()[]='; // исключаемые
var s:=ReadString('Введите строку:');
s.Where(x->Pos(x,Delim)=0).Println('');
Writeln('Четных цифр: ',s.Where(x->Pos(x,'02468')>0).Count)
end.
Тестовое решение:
Введите строку: This is a formiula: y:=2.18=3*14*sin(6.23*x+7.04);
Thisisaformiulay218314sin623x704
Четных цифр: 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Филипсия
16.04.2020 22:43
составить блок схему к двум задачам 1)построить блок схему Дан целочисленный массив с количеством элементов п. Вывести на печать те его элементы, индексы которых являются степенями...
александр12342
04.07.2019 05:00
Влетнем лагере на каждого участника полагается 30 г сахара в день.в лагере 103 человека.сколько килограммовых упаковок сахара понадобится на весь лагерь на 6 дней? написать программу...
lemon234
04.07.2019 05:00
Оцените объем одной страницы данного учебника в байтах...
delfin4
15.01.2021 12:58
ЯЗЫК ПАСКАЛЬПАША И КУБИКИУ маленького Паши было 5 кубиков с цифрами от 1 до 5 на каждом кубике. В не самый прекрасный день Паша обнаружил, что один из кубиков потерялся. Паше понять,...
mczuf
15.01.2021 12:58
Вам нужно закодировать методом Хаффмана сообщение АБАГБББАВАБВ. В качестве ответа предоставьте длины кодовых слов для каждой буквы. Например, если кодовое слово для буквы А=01100,...
Арина1666
15.01.2021 12:59
Розписати формулу з математичного виду на вид MS Excel для її вирішення, використовуючи формулу «ЕСЛИ»:...
tsudakatyap0bt0w
29.03.2021 20:58
написать код) 1) Задана квадратная матрица. Получить транспонированную матрицу (перевернутую относительно главной диагонали) и вывести на экран. 2) Задана матрица порядка n и число...
mike961
29.03.2021 20:56
дам1. Какой язык HTML, какова его функция? 2. Какие основные понятия имеет язык HTML?4. Что такое Web-страница?5. из-за какого протокола вышел язык HTML?...
nata1316
29.03.2021 20:55
Укажите размер диска в Мбайт, если кластер состоит из 8 секторов и на диске используется FAT16...
smail130
22.04.2020 18:39
Непольное ветвление алгоритм блок схема состовить ...
Популярные вопросы
Напишите уравнения реакций, при которых можно осуществить следующие превращения:...
3
Решите уравнение: (у+3)(у-3) -(2у-1)^2=4у-3у никак не могу решить сколько не...
1
Кзавтру ! вставьте пропущенные буквы: bo_rd , rul_r , penc_l , sh_ _pener , c_mputer...
1
Сопоставьте произведения средневековой и его автора 1. «декамерон» а. уильям ленгленд...
3
Вдвух коробках = кол-во конфет. после того как из одной взяли 14 конфет , а в другую...
3
Нерастворимое основание образуется при взаимодействии растворов веществ,формулы...
2
Вкниге 120 страниц. рисунки занимают 35% всей книги. сколько страниц занимают рисунки?...
2
По проводнику течет ток силой 3а, напряжение между концами проводника 20в. какую...
3
Вдревности люди пользовались песочными,солнечными и свечными часами.в течении 1...
1
Выберите правильную форму,поставьте необходимые окончания. бел.. жалюзи, кольраби,...
1
begin
var Delim:=' .,+-*/;:()[]='; // исключаемые
var s:=ReadString('Введите строку:');
s.Where(x->Pos(x,Delim)=0).Println('');
Writeln('Четных цифр: ',s.Where(x->Pos(x,'02468')>0).Count)
end.
Тестовое решение:
Введите строку: This is a formiula: y:=2.18=3*14*sin(6.23*x+7.04);
Thisisaformiulay218314sin623x704
Четных цифр: 7