Написать алгоритм и составить программу для вычисления суммы квадратов первых n членов натурального ряда.

katya8631 katya8631    3   22.05.2019 05:50    1

Ответы
aleksandrp462 aleksandrp462  17.06.2020 08:03

Программа получает на вход N, почле чего в цикле постепенно обрабатывает все натуральные числа от 1 до N включительно и в ячейку памяти s откладывает их квадраты.

 

program summa;

uses crt;

var N,a,s,i: integer;

begin

read(N); a:=0; s:=0;

for i:=1 to N do

begin

a:=a+1;

s:=s+(a*a);

end;

writeln(s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика