Написать 4 лёгкие программы на C++ 1. Напишите программу для вычисления суммы нечетных натуральных чисел с использованием оператора for.
2. Начав тренировки, спортсмен в первый день пробежал М км. Каждый день он увеличивал дневную норму на Р% нормы предыдущего дня. В какой день впервые спортсмен пробежит более K км?
3. Клиент оформил вклад на m тысяч рублей в банке под k% годовых. Через сколько лет сумма вклада превысит s тысяч рублей, если за это время клиент не будет брать деньги со счета.
4. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.

edinorogsasha edinorogsasha    1   12.11.2020 20:21    9

Ответы
home66589 home66589  12.12.2020 20:23

#include<iostream>

using namespace std;

int main()

"Шапка" для всех программ, я напишу функцию main. Что бы работало "шапку" надо каждый раз писать.

№1 (Задаче решается легче через формулу: 1 + 3 + 5 + … + ( 2 n − 1 ) = n ²)

{

unsigned int n, z; // z - начальная точка отрезка, n - конечная. (z, n > 0)

unsigned int S = 0; // S - сумма нечетных  

// cin >> n; - если надо использовать ввод через клавиатуру

z = 1; n = 11;

// вычисляет сумма натуральных нечетных чисел от z(1) до n(1). Если нужен другой отрезок смени значение z, n. В условии не сказан конкретный отрезок.

for(unsigned int i = z; i <= n; i += 2)

 S += i;

cout << S; // Если надо вывести значение на экран, опять же в условии сказано лишь вычислить сумму, про вывод не слова :(

return 0;

}

№2

{

double M, P, K;

cin >> M >> P >> K;

P = P / 100 + 1; // Что бы представить %, в виде числа.

int dayCounter = 0;

for(double i = M; i <= K; i *= P)

 dayCounter ++;

cout << dayCounter;

return 0;

}

№3 (Задача абсолютно такая же, как и 2-ая)

{

double m, k, s;

cin >> m >> k >> s;

k = k / 100 + 1; // Что бы представить %, в виде числа.

int yearsCounter = 0;

for(double i = m; i <= s; i *= k)

 yearsCounter ++;

cout << yearsCounter;

return 0;

}

№4(Если признаком окончанием последовательности является 0)

{

double s = 0,

averageS,

enteredNum;

int k = 0;

while(cin >> enteredNum && enteredNum)

 {

    if(enteredNum > 0) s += enteredNum;

    k ++;

 }

averageS = s / k;

cout << s << " " << averageS;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Fenef Fenef  12.12.2020 20:23

1)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   int amount = 0; // Сумма нечетных чисел

   int first, last; // Первое и конечное значения

   cin >> first >> last; // Вводим первое и конечное значения с клавиатуры

   for (int i = first; i <= last; i++) // Идём от первого до конечного значения включительно

   {

       if (i % 2 != 0) // Если значение переменной i делится на 2 без остатка

       {

           amount += i; // Суммируем этот элемент

       }

   }

   cout << amount; // Выводим ответ

}

2)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double m, p, k; // Переменные по условию

   int day = 1; // Мы уже знаем, сколько он пробежал в 1 день => переменная, хранящая дни, равна единице

   cin >> m >> p >> k; // Вводим значение с клавиатуры

   p = p / 100 + 1; // Переводим процент в число

   for (double i = m; i <= k; i *= p) // Идём, пока m ≤ k

   {

       day++; // Прибавляем единицу  

   }

   cout << day; // Выводим ответ

}

3)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double m, p, s; // Переменные по условию

   int year = 0; // Начинаем отсчёт с нулевого года

   cin >> m >> p >> s; // Вводим значение с клавиатуры

   p = p / 100 + 1; // Переводим процент в число

   for (double i = m; i <= s; i *= p) // Идём, пока m ≤ s

   {

       year++; // Прибавляем единицу  

   }

   cout << year; // Выводим ответ

}

4)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double amount = 0; // Сумма чисел последовательности

   int quantity = 0; // Количество чисел последовательности

   int number; // Переменная, хранящая значения последовательности

   double arithmetic_mean; // Переменная, хранящая среднее арифметическое

   cin >> number; // Вводим значение с клавиатуры

   while (number != 0) // Пока значение переменной number ≠ 0

   {

       if (number > 0) // Если переменная number - положительное число

       {

           amount += number; // Суммируем

           quantity++; // Количество = + 1

       }

       cin >> number; // Вводим значение с клавиатуры

   }

   arithmetic_mean = amount / quantity;  // Вычисляем среднее арифметическое

   cout << "Сумма = " << amount << endl << "Среднее арифметическое = " << arithmetic_mean;  // Выводим ответ

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика