Написание программы на языке c++, написать программу. : составьте программу которая вводит символы до знака $. пусть программа считает число введённых точек и выведет подсчитанное количество на экран монитора. . написано было в визуал студио 2015

nikakri14 nikakri14    3   30.03.2019 09:32    4

Ответы
hyyeblan5577 hyyeblan5577  27.05.2020 16:32

Привет, я тестировал на VS 2017, но разницы нет, я тебя уверяю (по крайней мере в данном случае).

Кратко об моём решении. Запускаю цикл и считываю символ в переменную, если это точка, добавляю к счётчику +1, если доллар - цикл прекращается.

Мой вариант решения:

#include <iostream>

using namespace std;

int main()

{

char symbol;

int counter = 0;

do

{

 cout << "Enter symbol -> ";

 cin >> symbol;

 if (symbol == '.') counter++;

} while (symbol != '$');

cout << "Dot's counter " << counter << endl;

cin.get();

cin.get();

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика