Надо составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа. расписать все четко

natacha18 natacha18    3   03.06.2019 00:00    13

Ответы
angrelygovo201 angrelygovo201  01.10.2020 17:36
Строками:
var s:string;
begin
WriteLn('vvedi chislo:');
ReadLn(s);
WriteLn('chislo cifr=',length(s));
ReadLn;
end;
Не строками:
var N,k:longint;
begin
write('N=');readln(N);
k:=0;
while N>0 do
begin
N:=N div 10;
k:=k+1;
end;
write('k=',k);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика